const regex = /Payment received NEFT \- Your account (\S+) has been credited for (\S+) from (\S+) vide Txn ref (\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Payment received NEFT \\- Your account (\\S+) has been credited for (\\S+) from (\\S+) vide Txn ref (\\S+)', 'gm')
const str = `Payment received NEFT - Your account account_number has been credited for some_amount from some_sender vide Txn ref some_ref_num.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);