#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![private|public|protected|static]\s)function\s.*?\(.*?\)\s?{"
Local $sString = "function (asdsa) {" & @CRLF & _
"static function (asdsa){" & @CRLF & _
"protected function (asdsa){" & @CRLF & _
"private function (asdsa){" & @CRLF & _
"public function (asdsa){"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")