const regex = /(?<![private|public|protected|static]\s)function\s.*?\(.*?\)\s?{/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![private|public|protected|static]\\s)function\\s.*?\\(.*?\\)\\s?{', '')
const str = `function (asdsa) {
static function (asdsa){
protected function (asdsa){
private function (asdsa){
public function (asdsa){`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}