using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![private|public|protected|static]\s)function\s.*?\(.*?\)\s?{";
string input = @"function (asdsa) {
static function (asdsa){
protected function (asdsa){
private function (asdsa){
public function (asdsa){";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}