use strict;
my $str = 'abcdef01234567890 \\path\\to\\file1.txt';
my $regex = qr/^.+? /ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";