import Foundation
let pattern = #"^.+? "#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"abcdef01234567890 \path\to\file1.txt"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)