re = /^.+? /i
str = 'abcdef01234567890 \\path\\to\\file1.txt'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result