const regex = /SET((.|[\r\n\u2028\u2029])*?)WHERE/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SET((.|[\\r\\n\\u2028\\u2029])*?)WHERE', 'g')
const str = `UPDATE pass
SET stato = -3, descr_stato = 'Scartata' WHERE pratica = '1458'
AND stato = 0
AND anno IN (2016, 2017, 2018);
UPDATE pass
SET stato = -3, descr_stato = 'Scartata'
WHERE pratica = '2383' AND stato = 0 AND anno IN (2020);`;
const subst = `WHERE`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);