use strict;
my $str = 'UPDATE pass
SET stato = -3, descr_stato = \'Scartata\' WHERE pratica = \'1458\'
AND stato = 0
AND anno IN (2016, 2017, 2018);
UPDATE pass
SET stato = -3, descr_stato = \'Scartata\'
WHERE pratica = \'2383\' AND stato = 0 AND anno IN (2020);';
my $regex = qr/SET((.|[\r\n\u2028\u2029])*?)WHERE/p;
my $subst = 'WHERE';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";