using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\sid=\""[^\""]*)/(?=[^\""]*\""[^>]*>)";
string substitution = @"-";
string input = @"<circle id=""a/b/c"" stroke=""#2C2C2C"" stroke-width=""2"" fill=""#FFF"" fill-rule=""nonzero"" cx=""141"" cy=""21"" r=""9""/><text id=""a/b/c-something"" font-size=""10"" fill=""#2C2C2C""><tspan x=""0"" y=""10"">a/b/c Something</tspan></text>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}