import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\sid=\\\"[^\\\"]*)/(?=[^\\\"]*\\\"[^>]*>)";
final String string = "<circle id=\"a/b/c\" stroke=\"#2C2C2C\" stroke-width=\"2\" fill=\"#FFF\" fill-rule=\"nonzero\" cx=\"141\" cy=\"21\" r=\"9\"/><text id=\"a/b/c-something\" font-size=\"10\" fill=\"#2C2C2C\"><tspan x=\"0\" y=\"10\">a/b/c Something</tspan></text>\n";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}