re = /(?<=\sid=\"[^\"]*)\/(?=[^\"]*\"[^>]*>)/m
str = '<circle id="a/b/c" stroke="#2C2C2C" stroke-width="2" fill="#FFF" fill-rule="nonzero" cx="141" cy="21" r="9"/><text id="a/b/c-something" font-size="10" fill="#2C2C2C"><tspan x="0" y="10">a/b/c Something</tspan></text>
'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result