const regex = /(?<!\S)axe(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)axe(?!\\S)', 'gm')
const str = `foo axe .axe axe`;
const subst = `sword`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);