use strict;
my $str = 'foo axe .axe axe';
my $regex = qr/(?<!\S)axe(?!\S)/mp;
my $subst = 'sword';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";