$re = '/(?<!\S)axe(?!\S)/m';
$str = 'foo axe .axe axe';
$subst = "sword";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;