import Foundation
let pattern = #"(?<!\S)axe(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"foo axe .axe axe"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"sword"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)