use strict;
my $str = 'Aug 7 14:14:43 : user1 : TTY=pts/53 ; PWD=/path2 ;
USER=root ; COMMAND=/path/to/cmd1
Aug 7 14:14:49 : user2 : TTY=pts/53 ; PWD=/usr/home ;
USER=root ; COMMAND=./myscript.sh -m name -o SCHEDULER
Aug 7 14:15:14 : user3 : TTY=pts/34 ;
PWD=/path ; USER=root ;
COMMAND=/usr/bin/egrep ^[a-z]*
/filename/toto1234
Aug 7 14:15:37 : user4 : TTY=unknown ; PWD=/opt/nagios ; USER=root ;
COMMAND=/path/to/less
/var/opt/otherfile
Aug 7 14:16:04 : user4 : TTY=pts/34 ;
PWD=/usr/local/bin/script ; USER=root ;
COMMAND=/usr/bin/egrep ^[a-z]*
/user/local/sbin/tata
';
my $regex = qr/(^\w{3}\s+\d+\s\d+:\d+:\d+)\s?:\s?(\w+?)\s+:.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}