// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\w{3}\s+\d+\s\d+:\d+:\d+)\s?:\s?(\w+?)\s+:.*").unwrap();
let string = "Aug 7 14:14:43 : user1 : TTY=pts/53 ; PWD=/path2 ;
USER=root ; COMMAND=/path/to/cmd1
Aug 7 14:14:49 : user2 : TTY=pts/53 ; PWD=/usr/home ;
USER=root ; COMMAND=./myscript.sh -m name -o SCHEDULER
Aug 7 14:15:14 : user3 : TTY=pts/34 ;
PWD=/path ; USER=root ;
COMMAND=/usr/bin/egrep ^[a-z]*
/filename/toto1234
Aug 7 14:15:37 : user4 : TTY=unknown ; PWD=/opt/nagios ; USER=root ;
COMMAND=/path/to/less
/var/opt/otherfile
Aug 7 14:16:04 : user4 : TTY=pts/34 ;
PWD=/usr/local/bin/script ; USER=root ;
COMMAND=/usr/bin/egrep ^[a-z]*
/user/local/sbin/tata
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}