import Foundation
let pattern = #"(^\w{3}\s+\d+\s\d+:\d+:\d+)\s?:\s?(\w+?)\s+:.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Aug 7 14:14:43 : user1 : TTY=pts/53 ; PWD=/path2 ;
USER=root ; COMMAND=/path/to/cmd1
Aug 7 14:14:49 : user2 : TTY=pts/53 ; PWD=/usr/home ;
USER=root ; COMMAND=./myscript.sh -m name -o SCHEDULER
Aug 7 14:15:14 : user3 : TTY=pts/34 ;
PWD=/path ; USER=root ;
COMMAND=/usr/bin/egrep ^[a-z]*
/filename/toto1234
Aug 7 14:15:37 : user4 : TTY=unknown ; PWD=/opt/nagios ; USER=root ;
COMMAND=/path/to/less
/var/opt/otherfile
Aug 7 14:16:04 : user4 : TTY=pts/34 ;
PWD=/usr/local/bin/script ; USER=root ;
COMMAND=/usr/bin/egrep ^[a-z]*
/user/local/sbin/tata
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)