# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\w{3}\s+\d+\s\d+:\d+:\d+)\s?:\s?(\w+?)\s+:.*"
test_str = ("Aug 7 14:14:43 : user1 : TTY=pts/53 ; PWD=/path2 ;\n"
" USER=root ; COMMAND=/path/to/cmd1\n"
"Aug 7 14:14:49 : user2 : TTY=pts/53 ; PWD=/usr/home ;\n"
" USER=root ; COMMAND=./myscript.sh -m name -o SCHEDULER\n"
"Aug 7 14:15:14 : user3 : TTY=pts/34 ;\n"
" PWD=/path ; USER=root ;\n"
" COMMAND=/usr/bin/egrep ^[a-z]*\n"
" /filename/toto1234\n"
"Aug 7 14:15:37 : user4 : TTY=unknown ; PWD=/opt/nagios ; USER=root ;\n"
" COMMAND=/path/to/less\n"
" /var/opt/otherfile\n"
"Aug 7 14:16:04 : user4 : TTY=pts/34 ;\n"
" PWD=/usr/local/bin/script ; USER=root ;\n"
" COMMAND=/usr/bin/egrep ^[a-z]*\n"
" /user/local/sbin/tata\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.