const regex = /(--wanted--)|("wanted")|(\(wanted\))|(wanted)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(--wanted--)|("wanted")|(\\(wanted\\))|(wanted)', 'g')
const str = `The "wanted" wanted to avoid the other --wanted-- (wanted) convict.`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);