$re = '/(--wanted--)|("wanted")|(\(wanted\))|(wanted)/';
$str = 'The "wanted" wanted to avoid the other --wanted-- (wanted) convict.';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;