import re
regex = re.compile(r"(--wanted--)|(\"wanted\")|(\(wanted\))|(wanted)")
test_str = "The \"wanted\" wanted to avoid the other --wanted-- (wanted) convict."
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)