re = /(--wanted--)|("wanted")|(\(wanted\))|(wanted)/
str = 'The "wanted" wanted to avoid the other --wanted-- (wanted) convict.'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result