package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^)]+(?:\))`)
var str = `Set 1 (2) Set 2 (2) Set 3 (2) Set 4 (2) [Choose Two]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}