const regex = /[^)]+(?:\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^)]+(?:\\))', 'gm')
const str = `Set 1 (2) Set 2 (2) Set 3 (2) Set 4 (2) [Choose Two]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}