// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^)]+(?:\))").unwrap();
let string = "Set 1 (2) Set 2 (2) Set 3 (2) Set 4 (2) [Choose Two]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}