$re = '/[^)]+(?:\))/m';
$str = 'Set 1 (2) Set 2 (2) Set 3 (2) Set 4 (2) [Choose Two]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);