#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?s)(?<!\\)("|')(?:[^\\]|\\.)*?\1|\S+"
Local $sString = "foo "bar \"baz\"" '\'quux\''" & @CRLF & _
"" & @CRLF & _
"'foo"bar' "baz'boz"" & @CRLF & _
"" & @CRLF & _
"hello "regex" & @CRLF & _
"" & @CRLF & _
"world\""" & @CRLF & _
"" & @CRLF & _
""escaped escape\\""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")