using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<!\\)(""|')(?:[^\\]|\\.)*?\1|\S+";
string input = @"foo ""bar \""baz\"" '\'quux\''
'foo""bar' ""baz'boz""
hello ""regex
world\""
""escaped escape\\""";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}