using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"messenger|zalo";
string input = @"chat.zalo.me
vietnamplus.vn/zalo/zalo
org.telegram.messenger
l.messenger.com
zalo/zalo/zalo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}