package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)messenger|zalo`)
var str = `chat.zalo.me
vietnamplus.vn/zalo/zalo
org.telegram.messenger
l.messenger.com
zalo/zalo/zalo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}