$re = '/messenger|zalo/m';
$str = 'chat.zalo.me
vietnamplus.vn/zalo/zalo
org.telegram.messenger
l.messenger.com
zalo/zalo/zalo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);