import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(m_\\w{3,}|m[A-Za-z0-9]\\w+|[A-Za-ln-z0-9]\\w{2,})$";
final String string = "m_a\n"
+ "m_abc\n"
+ "abc\n"
+ "m_m_xyz\n"
+ "ab\n"
+ "abc_m\n"
+ "zm_1\n"
+ "z_1\n"
+ "m_1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}