re = /^(m_\w{3,}|m[A-Za-z0-9]\w+|[A-Za-ln-z0-9]\w{2,})$/m
str = 'm_a
m_abc
abc
m_m_xyz
ab
abc_m
zm_1
z_1
m_1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end