import re
regex = re.compile(r"^(m_\w{3,}|m[A-Za-z0-9]\w+|[A-Za-ln-z0-9]\w{2,})$", flags=re.MULTILINE)
test_str = ("m_a\n"
"m_abc\n"
"abc\n"
"m_m_xyz\n"
"ab\n"
"abc_m\n"
"zm_1\n"
"z_1\n"
"m_1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")