const regex = /^(m_\w{3,}|m[A-Za-z0-9]\w+|[A-Za-ln-z0-9]\w{2,})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(m_\\w{3,}|m[A-Za-z0-9]\\w+|[A-Za-ln-z0-9]\\w{2,})$', 'mg')
const str = `m_a
m_abc
abc
m_m_xyz
ab
abc_m
zm_1
z_1
m_1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}