#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\b\d+[a-z]\d*\b.*"
Local $sString = "1921 abc abc abc 1k" & @CRLF & _
"" & @CRLF & _
"4320 abcs abc Apt 201b" & @CRLF & _
"" & @CRLF & _
"1250 abcd Ave Apt 3c" & @CRLF & _
"" & @CRLF & _
"61a abcd Ave" & @CRLF & _
"" & @CRLF & _
"1b abcd Ave" & @CRLF & _
"" & @CRLF & _
"39r abcd Rd" & @CRLF & _
"" & @CRLF & _
"16w750 abcd Ave" & @CRLF & _
"" & @CRLF & _
"abc 12a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")