package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\b\d+[a-z]\d*\b.*`)
var str = `1921 abc abc abc 1k
4320 abcs abc Apt 201b
1250 abcd Ave Apt 3c
61a abcd Ave
1b abcd Ave
39r abcd Rd
16w750 abcd Ave
abc 12a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}