const regex = /.*\b\d+[a-z]\d*\b.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\b\\d+[a-z]\\d*\\b.*', 'gm')
const str = `1921 abc abc abc 1k
4320 abcs abc Apt 201b
1250 abcd Ave Apt 3c
61a abcd Ave
1b abcd Ave
39r abcd Rd
16w750 abcd Ave
abc 12a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}