$re = '/.*\b\d+[a-z]\d*\b.*/m';
$str = '1921 abc abc abc 1k
4320 abcs abc Apt 201b
1250 abcd Ave Apt 3c
61a abcd Ave
1b abcd Ave
39r abcd Rd
16w750 abcd Ave
abc 12a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);