#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(JAN|FEVER)EIRO|MA(RÇ|I)O|ABRIL|JU[NL]HO|AGOSTO|(SETEM|OUTU|NOVEM|DEZEM)BRO"
Local $sString = "ABCDEF" & @CRLF & _
"ÇÇÇÇÇ" & @CRLF & _
"JANEIRO" & @CRLF & _
"FEVEREIRO" & @CRLF & _
"MARÇO" & @CRLF & _
"ABRIL" & @CRLF & _
"MAIO" & @CRLF & _
"JUNHO" & @CRLF & _
"JULHO" & @CRLF & _
"AGOSTO" & @CRLF & _
"SETEMBRO" & @CRLF & _
"OUTUBRO" & @CRLF & _
"NOVEMBRO" & @CRLF & _
"DEZEMBRO" & @CRLF & _
"janeiro" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")