import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(JAN|FEVER)EIRO|MA(RÇ|I)O|ABRIL|JU[NL]HO|AGOSTO|(SETEM|OUTU|NOVEM|DEZEM)BRO";
final String string = "ABCDEF\n"
+ "ÇÇÇÇÇ\n"
+ "JANEIRO\n"
+ "FEVEREIRO\n"
+ "MARÇO\n"
+ "ABRIL\n"
+ "MAIO\n"
+ "JUNHO\n"
+ "JULHO\n"
+ "AGOSTO\n"
+ "SETEMBRO\n"
+ "OUTUBRO\n"
+ "NOVEMBRO\n"
+ "DEZEMBRO\n"
+ "janeiro\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}