$re = '/(JAN|FEVER)EIRO|MA(RÇ|I)O|ABRIL|JU[NL]HO|AGOSTO|(SETEM|OUTU|NOVEM|DEZEM)BRO/m';
$str = 'ABCDEF
ÇÇÇÇÇ
JANEIRO
FEVEREIRO
MARÇO
ABRIL
MAIO
JUNHO
JULHO
AGOSTO
SETEMBRO
OUTUBRO
NOVEMBRO
DEZEMBRO
janeiro
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);