package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*@\w*.\w*)`)
var str = `email me! john@smith.com
e:john@smith.com m:555-555-5555
john@smith.com--personal email`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}