$re = '/(\w*@\w*.\w*)/';
$str = 'email me! john@smith.com
e:john@smith.com m:555-555-5555
john@smith.com--personal email';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);