import re
regex = re.compile(r"(\w*@\w*.\w*)")
test_str = ("email me! john@smith.com\n"
"e:john@smith.com m:555-555-5555\n"
"john@smith.com--personal email")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")