// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w*@\w*.\w*)").unwrap();
let string = "email me! john@smith.com
e:john@smith.com m:555-555-5555
john@smith.com--personal email";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}