import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<open>(?P<quote>['\"])|\\()(?P<relativeFile>(?:\\.\\.\\/)+.*?)(?P<params>[#\\?].*?|)?(?P<close>\\k<quote>|\\))";
final String string = " src: url('../fonts/levibrush-webfont.eot');\n"
+ " src: url('../fonts/levibrush-webfont.eot?#iefix') format('embedded-opentype'), url('../fonts/levibrush-webfont.woff') format('woff'), url('../fonts/levibrush-webfont.ttf') format('truetype'), url('../fonts/levibrush-webfont.svg#LeviBrushRegular') format('svg');\n"
+ "html {background:url(../images/bg-body.png) repeat scroll 0 0; color:;}\n"
+ "\"../../../../images/image.png\"(../../../../images/image.png)'../../../../images/image.png' \"../../../../images/image.png\" '../../../../images/image.png'\"../../../../images/image.png\"'../../../../images/image.png'";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}