import re
regex = re.compile(r"""
(?P<open>(?P<quote>['"])|\()(?P<relativeFile>(?:\.\.\/)+.*?)(?P<params>[#\?].*?|)?(?P<close>\k<quote>|\))
""", flags=re.VERBOSE)
test_str = (" src: url('../fonts/levibrush-webfont.eot');\n"
" src: url('../fonts/levibrush-webfont.eot?#iefix') format('embedded-opentype'), url('../fonts/levibrush-webfont.woff') format('woff'), url('../fonts/levibrush-webfont.ttf') format('truetype'), url('../fonts/levibrush-webfont.svg#LeviBrushRegular') format('svg');\n"
"html {background:url(../images/bg-body.png) repeat scroll 0 0; color:;}\n"
"\"../../../../images/image.png\"(../../../../images/image.png)'../../../../images/image.png' \"../../../../images/image.png\" '../../../../images/image.png'\"../../../../images/image.png\"'../../../../images/image.png'")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)